účinné od 1. 6. 2019Poskytování automatizovaného výstupuúčinné od 1. 6. 2019Oddíl 2

  1. účinné od 1. 6. 2019I. Způsob poskytování automatizovaného výstupu provozovatelem
    1. účinné od 1. 6. 2019Provozovatel poskytuje automatizovaný výstup v zašifrovaném komprimovaném datovém balíčku zapečetěném uznávanou elektronickou pečetí provozovatele tak, že jej zpřístupní na následující adrese přístupné šifrovaným autentizovaným přenosem pomocí protokolu HTTPS:

      účinné od 1. 6. 2019https://<URL>/<Název balíčku>.zip.p7e.p7s

      účinné od 1. 6. 2019Orgán vykonávající dozor přistupuje k automatizovanému výstupu vystavenému na této adrese metodou GET protokolu HTTP podle standardu RFC 7231.

      účinné od 1. 6. 2019
      Poskytování automatizovaného výstupu
      Část adresyUpřesnění
      <URL>Část adresy internetové stránky používaná k sestavení adresy, jejímž prostřednictvím provozovatel poskytuje orgánu vykonávajícímu dozor automatizovaný výstup.
      <Název balíčku>Název poskytnutého souboru s automatizovaným výstupem bez všech přípon.
  1. účinné od 1. 6. 2019II. Požadavky na dostupnost internetové adresy provozovatele

    účinné od 1. 6. 2019Internetová adresa poskytnutá provozovatelem pro účely poskytování automatizovaného výstupu musí být trvale veřejně přístupná prostřednictvím internetu a délka jednotlivého výpadku nesmí převýšit 24 hodin.

  1. účinné od 1. 6. 2019III. Potvrzení o přijetí automatizovaného výstupu

    účinné od 1. 6. 2019Orgán vykonávající dozor odešle potvrzovací balíček šifrovaným autentizovaným přenosem pomocí protokolu HTTPS metodou POST protokolu HTTP podle standardu RFC 7231.

    1. účinné od 1. 6. 2019V případě, že je poskytnutý automatizovaný výstup formálně správný, odešle orgán vykonávající dozor potvrzovací balíček na adresu:

      účinné od 1. 6. 2019https://<URL OK>?protokol=<Název balíčku>.ok.zip.p7e.p7s

    1. účinné od 1. 6. 2019V případě, že poskytnutý automatizovaný výstup není formálně správný, odešle orgán vykonávající dozor potvrzovací balíček na adresu:

      účinné od 1. 6. 2019https://<URL chyba>?protokol=<Název balíčku>.err.zip.p7e.p7s

    účinné od 1. 6. 2019Orgán vykonávající dozor vystaví potvrzovací balíček také na serveru, ke kterému má provozovatel přístup šifrovaným autentizovaným přenosem pomocí protokolu HTTPS.

    účinné od 1. 6. 2019
    Poskytování automatizovaného výstupu
    Část adresy pro zaslání potvrzovacího balíčkuUpřesnění
    <URL OK>Část adresy internetové stránky poskytnutá provozovatelem používaná k sestavení adresy, na kterou má být zaslán potvrzovací balíček v případě, kdy je poskytnutý automatizovaný výstup formálně správný.
    <URL chyba>Část adresy internetové stránky poskytnutá provozovatelem používaná k sestavení adresy, na kterou má být zaslán potvrzovací balíček v případě, kdy poskytnutý automatizovaný výstup není formálně správný.
    <Název balíčku>Název poskytnutého souboru s automatizovaným výstupem bez všech přípon.
  1. účinné od 1. 6. 2019IV. Potvrzovací balíček

    účinné od 1. 6. 2019V případě, že je poskytnutý automatizovaný výstup formálně správný, potvrdí orgán vykonávající dozor tuto skutečnost potvrzovacím datovým souborem s názvem <Název balíčku>.ok, obsahujícím informace o úspěšném zpracování balíčku.

    účinné od 1. 6. 2019V případě, že poskytnutý automatizovaný výstup obsahuje formální chyby, potvrdí orgán vykonávající dozor tuto skutečnost potvrzovacím datovým souborem s názvem <Název balíčku>.err, obsahující počítačový výstup ze zpracování automatizovaného výstupu.

    účinné od 1. 6. 2019
    Poskytování automatizovaného výstupu
    Část názvu potvrzovacího datového souboruUpřesnění
    <Název balíčku>Název poskytnutého souboru s automatizovaným výstupem bez všech přípon.
    1. účinné od 1. 6. 2019Potvrzovací balíček vytvoří orgán vykonávající dozor následujícím postupem:
      1. účinné od 1. 6. 20191. Z potvrzovacího datového souboru vytvoří orgán vykonávající dozor komprimovaný datový balíček.
      2. účinné od 1. 6. 20192. Komprimovaný datový balíček zašifruje orgán vykonávající dozor veřejným klíčem provozovatele.
      3. účinné od 1. 6. 20193. Zašifrovaný komprimovaný datový balíček zapečetí orgán vykonávající dozor svou kvalifikovanou elektronickou pečetí a kvalifikovaným časovým razítkem.

účinné od 1. 6. 2019Společná ustanoveníúčinné od 1. 6. 2019Oddíl 3

  1. účinné od 1. 6. 2019I. Vytvoření komprimovaného datového balíčku

    účinné od 1. 6. 2019Při vytváření komprimovaného datového balíčku z jednoho nebo více souborů se tyto soubory zkomprimují do jednoho souboru metodou ZIP podle standardu ISO/IEC 21320-1:2015.

    účinné od 1. 6. 2019Soubory v datovém balíčku nejsou uspořádány do adresářů.

    účinné od 1. 6. 2019Název souboru s komprimovaným datovým balíčkem se opatří příponou zip.

  1. účinné od 1. 6. 2019II. Šifrování souboru

    účinné od 1. 6. 2019Při šifrování souboru veřejným klíčem se zašifrovaný soubor uloží ve formátu Cryptographic message syntax (CMS) s využitím typu obsahu Enveloped-Data podle standardu RFC 5652.

    účinné od 1. 6. 2019Název zašifrovaného souboru, včetně případné přípony, se opatří příponou p7e.

  1. účinné od 1. 6. 2019III. Pečetění souboru provozovatelem

    účinné od 1. 6. 2019Při pečetění souboru provozovatel opatří soubor uznávanou elektronickou pečetí ve formátu CAdES podle standardů ČSN ETSI EN 319 122-1 V1.1.1 a ČSN ETSI EN 319 122-2 V1.1.1.

    účinné od 1. 6. 2019Zapečetěná data, elektronická pečeť a případné časové razítko jsou uloženy v jednom souboru, jehož název, včetně případné přípony, se opatří příponou p7s.

  1. účinné od 1. 6. 2019IV. Pečetění souboru orgánem vykonávajícím dozor

    účinné od 1. 6. 2019Při pečetění souboru orgán vykonávající dozor opatří soubor kvalifikovanou elektronickou pečetí s kvalifikovaným časovým razítkem ve formátu CAdES-B-T podle standardů ČSN ETSI EN 319 122-1 V1.1.1 a ČSN ETSI EN 319 122-2 V1.1.1.

    účinné od 1. 6. 2019Zapečetěná data, kvalifikovaná elektronická pečeť a kvalifikované časové razítko jsou uloženy v jednom souboru, jehož název, včetně případné přípony, se opatří příponou p7s.

  1. účinné od 1. 6. 2019V. Šifrovaný autentizovaný přenos pomocí protokolu HTTPS
    1. účinné od 1. 6. 2019Při šifrovaném autentizovaném přenosu pomocí protokolu HTTPS musí být splněny následující podmínky:
      1. účinné od 1. 6. 20191. Použitým protokolem musí být HTTP/1.1 podle standardu RFC 7230 s možností použití hlaviček „Accept-Ranges“, „Range“ a „Content-Range“ podle standardu RFC 7233.
      2. účinné od 1. 6. 20192. Přenos musí probíhat prostřednictvím kryptografického protokolu Transport Layer Security (TLS) ve verzi alespoň 1.2 podle standardu RFC 5246.
      3. účinné od 1. 6. 20193. Přístup k internetové stránce je autentizován kvalifikovaným klientským certifikátem ve formátu X.509 podle standardů RFC 5246 a RFC 5280.
  1. účinné od 1. 6. 2019VI. Obecné požadavky na používané kryptografické prostředky

    účinné od 1. 6. 2019Použité kryptografické algoritmy, kryptografické klíče a certifikáty musí splňovat požadavky na kryptografické prostředky podle vyhlášky upravující kybernetickou bezpečnost.

  1. účinné od 1. 6. 2019VII. Dekadické kódy znaků

    účinné od 1. 6. 2019Dekadické kódy znaků představují pro účely poskytování automatizovaného výstupu kódy znaků ze znakové sady Unicode v souladu se standardem RFC 3629.

  1. účinné od 1. 6. 2019VIII. Použití strojopisného písma v této příloze

    účinné od 1. 6. 2019V případě, že je určitý text v této příloze uveden ve strojopisném písmu, uvede se přesně v uvedeném znění. Při tom platí, že znak ˽ představuje mezeru (znak s dekadickým kódem 32), znaky 0 1 2 3 4 5 6 7 8 9 představují číslice (znaky s dekadickým kódem 48 až 57), znaky A B C D E F G H I J K L M N O P Q R S T U V W X Y Z představují velká písmena bez diakritiky (znaky s dekadickým kódem 65 až 90), znaky a b c d e f g h i j k l m n o p q r s t u v w x y z představují malá písmena bez diakritiky (znaky s dekadickým kódem 97 až 122), znak _ představuje podtržítko (znak s dekadickým kódem 95) a znak . představuje tečku (znak s dekadickým kódem 46).

  1. účinné od 1. 6. 2019IX. Použité standardy
    účinné od 1. 6. 2019
    Poskytování automatizovaného výstupu Společná ustanovení
    Označení standarduStandard
    ČSN ETSI EN 319 122-1 V1.1.1Elektronické podpisy a infrastruktury (ESI) - Digitální podpisy CAdES - Část 1: Stavební bloky a základní podpisy CAdES
    ČSN ETSI EN 319 122-2 V1.1.1Elektronické podpisy a infrastruktury (ESI) - Digitální podpisy CAdES - Část 2: Rozšířené podpisy CAdES
    ISO 4217:2015Codes for the representation of currencies
    ISO/IEC 21320-1:2015Information technology - Document Container File - Part 1: Core.
    RFC 3339Date and Time on the Internet: Timestamps
    https://tools.ietf.org/html/rfc3339
    RFC 3629UTF-8, a transformation format of ISO 10646
    https://tools.ietf.org/html/rfc3629
    RFC 5246The Transport Layer Security (TLS) Protocol Version 1.2
    https://tools.ietf.org/html/rfc5246
    RFC 5280Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile
    https://tools.ietf.org/html/rfc5280
    RFC 5652Cryptographic Message Syntax (CMS)
    https://tools.ietf.org/html/rfc5652
    RFC 7230Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and Routing
    https://tools.ietf.org/html/rfc7230
    RFC 7231Hypertext Transfer Protocol (HTTP/1.1): Semantics and Content
    https://tools.ietf.org/html/rfc7231
    RFC 7233Hypertext Transfer Protocol (HTTP/1.1): Range Requests
    https://tools.ietf.org/html/rfc7233#section-2.3